Application Errors
Invalid / empty name error
Error message
Cause
This error indicates that the application name field has been left empty.
Solution
This error can be fixed by editing the application name field and providing a non-empty string as the application name.
Duplicate name error
Error message
Cause
This error indicates that the name being assigned to the entity has been used before.
Solution
JavaScript reserved keywords and the window object methods and properties can't be used as entity names. You can fix the error by assigning a new unique name to the entity.
Login / signup errors
Account already registered error
Error message
Cause
This error indicates that the email used to sign up has already been used before.
Solution
This error can be fixed by either using a different email to signup or doing login
instead of signup
Reset password error
Error message
Cause
This error appears when the user attempts to log into the Appsmith platform with invalid email and/or password.
Solution
If you are unable to log in due to forgotten credentials, it's recommended to reset your account password. This can be done with the "Forgot Password" button on the Appsmith sign-in page; the page prompts you for the email address associated with your account, and then Appsmith sends an email to that address with a link for creating a new password.
Alternatively, you may be able to access your account by using an SSO method like Google or GitHub. If you use SSO with an account that has the same email address as the one you normally use to log in via email and password, you should be signed in successfully.
If you need to reset your password while using a self-hosted instance of Appsmith, the instance must first be configured to send email notifications.
No user error
Error message
Cause
The error indicates that the email provided to reset the password isn't registered with Appsmith.
Solution
You can fix the error by providing an email that has been used to register with Appsmith before. Alternatively, any new un-registered email can be used to create a new account using the sign-up option.
Unable to log in with SSO
If you configure Single Sign-On (SSO) before setting up a custom domain, you may encounter issues when trying to log in. In such cases, you may be redirected to the URL https://user/login?error=true
.
Error Message
If you check the container logs, you would see an error as shown below:
In the login failure handler. Cause: [invalid_client] AA**********: The reply address 'http://<IP>/login/oauth2/code/oidc' does not match the reply address 'https://<APPSMITH_CUSTOM_DOMAIN>/login/oauth2/code/oidc' provided when requesting Authorization code.
Cause
This error means that you have configured SSO before configuring the custom domain.
Solution
To resolve the issue, go to Admin Settings > Authentication > OIDC/SAML, disconnect the configured SSO method and set up a new SSO configuration.
Page access error
Error message
Cause
This message indicates one of the following:
- The page URL is invalid.
- The User doesn't have permission to access the page.
Solution
You can fix the error by requesting access permission for the page from the admin/developer
.